Crashing While Downloading MonolithRP Assets

  • Looking for our server(s)? Go to our servers page after you've subscribed to our content pack. Hope you enjoy them!
  • You can purchase Premium Membership to enhance your game experience and support our community!
  • Meet other members and stay updated in our Discord and Steam Group. Find out how to get permissions on Discord here.

bingbong

New Member
Feb 27, 2019
2
2
3
22
Hey, so I've been having crashes for about the past week when trying to load into the server. It always hangs for about 30 seconds and then crashes immediately once it gets to downloading the riotshield material assets (specifically materials/arleitiss/riotshield/shield_gripbump.vtf.b...). I've already verified integrity of game cache about ten times, power cycled my router, uninstalled then reinstalled Garry's Mod, uninstalled Garry's Mod, deleted the entirety of my Gmod folder, then reinstalled it, used both the base and chromium branches of Gmod through all of these iterations of uninstalling, verifying and reinstalling, uninstalled Gmod, deleted the entirety of the Gmod folder again, restarted my PC, and reinstalled it again, tried about every combination of video settings I could think of, subscribed to all the Truenorth/Monolith Workshop content - still crashed at that same point - and unsubscribed from all workshop content - still no difference - and I'm not really sure of what else I can really do to get it working. I'm able to load into every other one of my regular servers so not sure what the deal is. Anything I can try beyond all these troubleshooting steps to get connected to the server on my PC? Outside of Gmod everything is up-to-date on my PC so really not sure what could be causing it to crash at this point.
 
  • Like
Reactions: LosoLoaded

rako

MRP Moderator
MRP Moderator
Developer
Jun 15, 2017
126
120
43
20
Ireland
6349
Try to remove those folders and reconnect. Don't use chromium for now.

Are you on windows?
 
  • Like
Reactions: LosoLoaded

bingbong

New Member
Feb 27, 2019
2
2
3
22
Looks like that allowed me to connect just fine, appreciate it. Chromium beta also works now alongside the base game. Am on Windows. Anything I can really do to fix this in case it happens to pop up again other than deleting those folders again?
 
  • Like
Reactions: LosoLoaded

rako

MRP Moderator
MRP Moderator
Developer
Jun 15, 2017
126
120
43
20
Ireland
Just do it again, cache gets too big and the amount of shit in memory causes clients to crash.
This will eventually happen as you join many different servers, sadly.
 
  • Like
Reactions: LosoLoaded