why is my game stuck at the initializing screen?

  • Looking for our server(s)? Go to our servers page after you've subscribed to our content pack. Hope you enjoy them!
  • You can purchase Premium Membership to enhance your game experience and support our community!
  • Meet other members and stay updated in our Discord and Steam Group. Find out how to get permissions on Discord here.
  • Are you interested in helping and being engaged in the community further? Apply for a Staff Position!
Status
Not open for further replies.

Menacing

Monolith Newcomer
Apr 25, 2022
10
1
3
15
i have deleted all my addons and re-installed gmod but nothing seems to work
 

Marwan Mario

Monolith Rookie
Apr 1, 2021
16
30
13
If you see this error in your console:

Code:
[ERROR] gamemodes/darkrp/gamemode/modules/mono_message/cl_mono_message.lua:23: bad argument #1 to 'ipairs' (table expected, got nil)
  1. ipairs - [C]:-1
   2. v - gamemodes/darkrp/gamemode/modules/mono_message/cl_mono_message.lua:23
    3. unknown - lua/includes/modules/hook.lua:96

Go to your garrysmod\data\monolith\mono_message folder and delete the files inside it. (Make sure to take a backup if you want to save your Monophone messages.)

Someone had the same issue yesterday, and after trying every possible solution with him, this was the only fix that worked.

If you see any other errors, other than the one above, please post them here or contact me on discord Marwan#2097
 
Last edited:
  • Like
Reactions: toohightogame

Menacing

Monolith Newcomer
Apr 25, 2022
10
1
3
15
If you see this error in your console:

Code:
[ERROR] gamemodes/darkrp/gamemode/modules/mono_message/cl_mono_message.lua:23: bad argument #1 to 'ipairs' (table expected, got nil)
  1. ipairs - [C]:-1
   2. v - gamemodes/darkrp/gamemode/modules/mono_message/cl_mono_message.lua:23
    3. unknown - lua/includes/modules/hook.lua:96

Go to your garrysmod\data\monolith\mono_message folder and delete the files inside it. (Make sure to take a backup if you want to save your Monophone messages.)

Someone had the same issue yesterday, and after trying every possible solution with him, it turned out this was the fix.

If you see any other errors, other than the one above, please post them here or contact me on discord Marwan#2097
Thanks a lot! thats the only thing that worked
 
  • Like
Reactions: Marwan Mario

senmithrarin

Monolith Newcomer
Sep 17, 2018
14
5
3
I've gotten stuck here before too, so if it happens again (or if another player is struggling with this and comes across this thread) -

1) Make sure Steam didn't start automatically downloading other games/updates and try to rejoin.

2) Use the x64 bit version of Garry's Mod. This is accessible by right-clicking on the game in your Steam library, selecting properties, and then betas.

Follow Marwan's advice first, but these have also helped me in the past when I've gotten stuck.
 
  • Like
Reactions: toohightogame

JucaMais

Monolith Senior
May 1, 2019
453
606
93
Brazil
www.youtube.com
moving your Gmod to a SSD might fix that issue
 

Thegamingshain

MRP Senior Administrator
MRP Senior Administrator
Forum Moderator
Report Management
Marketing Team
Event Team
MRP Recruitment Team
Police Command
Nov 3, 2019
697
82
43
Moved to solved & Sticked.
 
Status
Not open for further replies.